1. Welcome to Planet Cyrene Forum!

    You appear to be browsing cyreneforum.com as a guest user. Did you know that if you sign up with an account, you get access to all kinds of additional privileges, and are then able to join the discussions?

    Already a member? Login Now!

Bug Report Maze Hammer Speed not working

Discussion in 'Technical - Suggestions and Bug Reports' started by JooGooGun, Sep 2, 2020.

  1. JooGooGun
    • Cyrene Pioneer

    JooGooGun New Member

    Joined:
    Aug 3, 2020
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Speed buff from the hammer will not work when equipping it. Seems other items (Melee amp with life steel) are having the same issues.

    If you have the hammer equipped when logging out and log back into game the speed buff is applied as normal until you equip another item and back to the hammer then the buff no longer applies.
     
  2. Kris | Cyrene
    • Administrator
    • Moderator
    • Cyrene Staff
    • Cyrene Pioneer

    Kris | Cyrene Lo and Behold, the Fixer of Bugs Staff Member
    Cool

    Joined:
    Nov 14, 2011
    Messages:
    1,659
    Likes Received:
    1,672
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    A man of many hats and talents.
    Location:
    Chiang Mai, Thailand // Orange County, CA
    Home Page:
    Hey JooGooGun,

    Yeah, it's nothing that got changed by our side as far as I understand it's happening with several other items in EU at the moment.

    You can see it still has the buff but at this time we believe it's a universe wide and are waiting to hear more about it from MA.

    Cheers,
    Kris
     
    JooGooGun likes this.

Share This Page